Scheduled for February 12, 2026 at 3:30 AM – 5:30 AM
Affects
Content Delivery Network (CDN)
Under maintenance from 3:30 AM to 5:30 AM
Completed
February 12, 2026 at 5:30 AMCompleted
February 12, 2026 at 5:30 AMMaintenance has completed successfully
In progress
February 12, 2026 at 3:30 AMIn progress
February 12, 2026 at 3:30 AMMaintenance is now in progress
Planned
February 12, 2026 at 3:30 AMPlanned
February 12, 2026 at 3:30 AMWe are performing a rolling upgrade of a portion of edge servers in our network. To minimize downtime, traffic will be rerouted away from each server during the upgrade. No downtime is expected.