Skip2 Networks - SSL/TLS Certificate Issue – Incident details

SSL/TLS Certificate Issue

Resolved
Degraded performance
Started 10 days agoLasted 25 minutes

Affected

Content Delivery Network (CDN)
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Incorrect/expired SSL/TLS certificates are being served for a subset of sites. We are investigating.